Tuesday, February 2, 2010

TNS-12533: TNS:illegal ADDRESS parameters

I kept receiving this error recently but until today, never bothered to investigate it. To get around it, I would just comment out the bottom half (where the problem was) of the tnsnames file.

Today I had enough.

I removed all but the top most entry, saved the file and did a tnsping <first_entry>.

OK (40 msec)

I added in the second entry, tnsping <second_entry>

OK (210 msec)

I added in the third entry

TNS-12533: TNS:illegal ADDRESS parameters

Removed it.

Success.

WTF?
 TESTING = 
(DESCRIPTION =
(ADDRESS =
(PROTOCOL = TCP)
(HOST = localhost)
(PORT = 1521)
)
(CONNECT_DATA =
(SERVICE_NAME = TESTING)
)
)
It's probably difficult to see...maybe a picture would do better.

see it?

How about now?

hidden stuff

Still don't see it?

still?

I almost gave up as well.

This should help.

yup, stupid huh?

A freaking space? Really? 8+ years and this is the very first time I am seeing this...seems strange I haven't encountered this before.

16 comments:

Coskan Gundogar said...

Welcome to the club :)

Anonymous said...

it is common error.
when save into unix machine after edit the file in windows with DOS format.
please remember save it as unix format.

Bradd Piontek said...

Don't you know you should be using the 'netmgr' utility to create these. What are this fancy CLI tools you are using :)

oraclenerd said...

Shouldn't you be torturing @purlygirl tonight instead of me?

Bradd Piontek said...

okay, I'll stop torturing you and reading your blog *sniff*

Anonymous said...

Thanks a lot. I got the same error from today morning and didnt have a clue what could be wrong as the same tns file worked for my previous builds. It is working after I remove the space.

Anonymous said...

Great post, helped me fix the error. I was sent a TNS names entry and wasn't able to connect even though the instance was on the same server as another production system that I was able to connect to and it was from the same TNS file. I saved the file in UNIX format and then resaved as Windows and it worked. Something so simple yet so frustrating.

oraclenerd said...

Glad it helped...who knew it could be something so tiny as a space?

chet

Anonymous said...

Thanks Google and thanks to you fantastic eye !!!

khushboo said...

Thanks a lotttt, it worked for me as well...Wasted one whole day in fixing it, but he entry looked fine...and now I realize wat was going

Paul Eden said...

Great post! Thanks.

Arremelle said...

This just got me as well! for me it was the entry that proceeded after the TNS which I was getting the fail on. Thanks for the great blog.

Rohit N said...

I too faced a similar rouge space causing said error. Your article saved a several minutes (dare I say hours) troubleshooting the same.

Appreciate you taking the time to post so that people like me can save themselves.

Thanks.

Rohit N.

Gilberto Pe-Curto said...

I am having this error now.
I am going to try solve it using this hint.

And if this is the problem i am going to cut my tongue after...

Gilberto Pe-Curto said...

I am curring battleing with this error.
I will try to solve it using this hint and if this is the case i am going to cut my tongue after...

Mats Mälis said...

At last i got i to work
Thanks !